So many thoughts. So little time.

Tag Archives: CamStudio

CamStudio Settings to Keep Audio and Video in Sync

I just created this video after a bit of trial and error (and research!) that demonstrates how to set up:

CamStudio 2.6 Beta (official download link)

so that the audio and video stay in synchronization throughout the length of the video.
(Or download the Most Stable Camstudio 2.0 release)
Getting CamStudio to synchronize the video to the audio requires that
the “Playback Rate” in Video Options divides evenly into 1000 milliseconds,
with the result being placed in the entry that goes in the box above it, “Capture Frames Every”. This must be a whole number (no fractions).

This basically means that you have five options for playback rate/frames per second
(as CamStudio does not allow fractional entries in the “Capture Frames Every” box).

You must use, therefore, 40 milliseconds with 25 frames/sec, or
50 milliseconds with 20 frames/sec, or 100 milliseconds with 10 frames per second,
or, if you are a mad scientist, 20 milliseconds with 50 frames/sec or 25 milliseconds with 40 frames/sec.
The first two settings mentioned are plenty adequate for 90% of applications, though.

Any other settings will cause a lag to develop in the audio that will get worse and worse as time passes.

This helpful information came from the following two links as sources:
http://en.wikibooks.org/wiki/Screencasting_with_CamStudio
http://en.wikibooks.org/wiki/Creating_Screencasts

Though I’ve seen it often stated that you can use 15 fps with a
“Capture Frames Every” setting of 66, that still sums to 990 (15 X 66), as does 30 fps and 33 (30 X 33).

Those settings will slowly cause lagging to occur.

I haven’t tested whether it will matter sufficiently in a 10-minute-MAX
YouTube video yet, but it probably will be a problem even at that length.

The settings that multiply to equal 1000 are the best optimized ones,
as 1000 milliseconds is equal to 1 second, but 990 milliseconds is clearly not!

I hope people find that helpful, and try to create their own screencasts.

[Edit: 03/23/10] Although these settings keep the sound and video in sync, they are not the only important ones. It is important to also set your video display settings in Windows so that “Hardware Acceleration” is turned completely off to avoid mouse jitter issues and other problems. Open the Display Settings control panel (right-click on the desktop background and select “Properties”), then select the “Settings” tab. From there, select the “Advanced” button. Once in there, select the “Troubleshoot” tab, where you will find the “Hardware Acceleration” slider. Slide that all the way to the left and hit the “Apply” button. Don’t forget to set this back again when you are done screen recording. For recording Games and such, you may have to try setting the slider at higher settings for game functionality to be adequate.

Later, from a request in a comment at YouTube, I recorded this how-to describing how to get sound from the “Stereo Mix”, so you can record what you hear on your speakers (as well as the microphone if you have one!) I had the settings a little hot for this microphone, so pardon the occasional distortion…

For people using Realtek HD Audio Input and a few other audio cards, you will need to allow the stereo mix to appear (enable it) and then make it the active input:

1. Enter the Sounds and Audio Devices control panel.

2. Click on the “Audio” Tab at the top.
Click the Sound Recording “Volume” button.


You can also get to the this panel from the CamStudio
Options/Audio Options/Audio Options for Microphone “Volume” button:

3. In the Recording Controls panel, drop down the “Options” menu and select “Properties”


4. Make sure “Stereo Mix” is checked and click ok.

5. Then, in the “Record” Section look for “Stereo Mix” and select it as your input:

Keep the volume level on Stereo Mix pretty low so it doesn’t clip.(distort)

6. You now can use the regular Master Volume sliders to control the mix.
Remember, the Mic input here in the “Master Volume” control is usually muted by default, so if you are using the mic input, be certain to un-mute it! BTW – the sound from your media players, browsers, etc. is coming through the “Wave” input slider.

If you have trouble with this, there are excellent videos on the subject at YouTube.